Что такое RMS Удаленный доступ

RMS Удаленный доступ (Remote Manipulator System) — это программа для удаленного администрирования компьютеров в локальных и глобальных сетях. В окне, размер которого можно менять, вы видите экран удаленного компьютера и можете управлять им мышью и клавиатурой.

Remote Manipulator System (RMS) предоставляет быстрый, безопасный и удобный доступ к удаленным компьютерам и поддерживает соединения через локальные сети (LAN) и сети широкого доступа — WAN (Internet). Помимо управления мышью и клавиатурой RMS предоставляет набор других утилит, полезных системному администратору, например, передача файлов, диспетчер задач, удаленный запуск, перехват звуковых сигналов удаленной машины и многое другое.

Несмотря на широкий функционал, Remote Manipulator System занимает минимум памяти, экономно использует ресурсы процессора, а так же может быть настроен на работу в медленных сетях (на базе EDGE, GPRS), благодаря возможности работы в т.н. экономичном режиме. Все данные, передаваемые по сети, сжимаются и шифруются.

Главное окно модуля Клиент

Главное окно модуля Клиент

Продукт RMS Удаленный доступ состоит их трех основных компонентов:

·Хост (Host) — эта часть устанавливается на удаленном компьютере (возможна удаленная установка).

·Клиент (Viewer) — эта часть устанавливается на компьютере администратора, с помощью нее можно управлять уделенными компьютерами.

·Сервер (Mini Internet-ID сервер) — повторяет функциональность нашей глобальной системы Internet-ID, предназначенной для работы удаленного доступа по ID, через NAT и сетевые экраны.

Ключевые особенности продукта:

·Высокая производительность, как в локальной сети, так и в медленных сетях.

·Клиент совместим с Windows 11/10/8/7/Vista/XP/2003/2008/2012/2016/2019/2022, Linux Ubuntu 16+, Astra Linux "Орел", ALT Linux 8 и новее, macOS 10.12 Sierra и новее. Android и iOS.

·Хост совместим с Windows 11/10/8/7/Vista/XP/2003/2008/2012/2016/2019/2022

·Сервер совместим с Windows x64 - 11/10/8/7/Vista/2008/2012/2016/2019/2022

·Широкий спектр режимов работы программы — передача файлов, удаленный диспетчер задач и устройств, Wake-On-LAN и многое другое.

·Удаленная установка. RMS легко установить во всей локальной сети, не вставая со своего рабочего места.

·Возможность настроить программу на работу в условиях сложной топологии сети, благодаря таким функциям, как "Соединение через" и "Обратное соединение".

·Мультиязычный интерфейс.

·Безопасность. Все данные шифруются с использованием TLS 1.2.


Как пользоваться RMS

Общий принцип работы Remote Manipulator System состоит в том, что на все удаленные контролируемые компьютеры в сети устанавливается Хост (Host). Администраторы устанавливают у себя клиентские модули — Клиенты (Viewer). Хост устанавливается в виде системного сервиса и должен быть запущен в момент, когда Клиент устанавливает соединение или контролирует удаленный компьютер.

Терминология

·Remote Manipulator System (RMS) — продукт компании TektonIT, состоящий из двух программ — Клиент и Хост.

·Хост — программа, которая устанавливается на удаленный компьютер. С помощью этой программы, Клиент осуществляет контроль удаленного компьютера.

·Клиент — программа, которая устанавливает сетевое соединение с Хостом, установленном на удаленном компьютере и осуществляет контроль над сервером в нескольких различных режимах соединения.

·Режим соединения — способ управления удаленным компьютером. RMS поддерживает несколько режимов соединения: управление, просмотр, передача файлов, диспетчер задач, диспетчер устройств, терминал, управление питанием, удаленный запуск, запись удаленного экрана по расписанию.


Особенности и функции

Совместимость с ОС Windows, начиная с XP и заканчивая 11

Удобство и простота установки

RMS крайне просто распространять и устанавливать как в локальных, так и глобальных сетях. Имеется возможность создать свой собственный дистрибутив с уже предустановленными настройками. Продукт можно установить несколькими способами:

·Классический. С помощью инсталлятора, запустив его локально на целевом компьютере.

·С помощью функции удаленной установки, встроенной в R-Viewer (можно применять как в домене, так и в обычной сети).

·С помощью групповой политики безопасности. RMS поставляется в виде msi-дистрибутива, таким образом можно воспользоваться возможностями серверных ОС для распространения программы в сети (можно применять только в домене).

Безопасность

Все данные, передаваемые RMS'ом по сети шифруются с помощью надежных алгоритмов шифрования, сертифицированных корпорацией Microsoft. Уровень безопасности можно установить в настройках сервера. Доступны две подсистемы безопасности: защита паролем и система безопасности Windows (active directory). Так же имеется возможность привязать RMS-Server только к одному определенному сетевому интерфейсу.

Уникальная технология видеозахвата

Система видеозахвата RMS дает непревзойденные результаты скорости работы программы, без использования драйвера ядра, что позволяет избежать конфликтов с оборудованием и драйверами. Так же RMS позволяет перехватывать оверлейное видео, при этом не отключая аппаратное ускорение, как это происходит при использовании стандартного драйвера захвата.

Internet-ID

Благодаря функции «Internet-ID», можно настроить удаленный доступ к компьютеру через Интернет без внешнего IP адреса, не обладая специальными навыками системного администратора. Удаленное администрирование стало намного проще. Internet-ID "пробивает" сетевые экраны и NAT.

Перетаскивание файлов и каталогов (Drag and Drop)

RMS обладает глубокой интеграцией с системным механизмом перетаскивания файлов и папок. Их можно перетаскивать непосредственно в окно удаленного экрана и из него, что позволяет максимально упростить работу с файлами. Модуль передачи файлов так же полностью поддерживает этот механизм.

Технология обратных соединений

Теперь RMS поддерживает технологию т.н. обратных соединений (callback). Её суть сводится к тому, что инициатором соединения теперь может выступать сервер. Это позволяет работать в сетях, где сервер находится за сетевым экраном или не имеет внешнего IP-адреса. Обратные соединения могут устанавливаться как вручную пользователем на компьютере с RMS-Server'ом, так и в автоматическом режиме.

Поддержка мультимониторных систем

Если на удаленном компьютере имеется несколько мониторов, RMS позволяет их просматривать или управлять ими в одном окне одновременно, либо переключаться на нужный монитор.

Перехват звуковых сигналов удаленного компьютера

RMS позволяет передавать на ваш компьютер все звуки, которые воспроизводятся на удаленном компьютере.

Быстрая система поиска Хостов в сети

Новая система поиска позволяет задавать несколько диапазонов IP адресов, по которым производить поиск серверов. Сканирование диапазона занимает считанные секунды. После того, как система поиска составит список компьютеров, на которых установлен Хост, его легко добавить с адресную книгу.

Масштабируемые эскизы экранов удаленных компьютеров в списке соединений

Возможность выбрать режим просмотра списка подключений, при котором вместо иконок, символизирующих удаленные серверы, отображаются непосредственно обновляемые скриншоты удаленных экранов, размер которых можно легко менять.

Wake-On-Lan

WOL (англ. Wake-on-LAN — пробуждение по локальной сети) — технология, позволяющая удаленно «пробудить» компьютер.

Многоязычный пользовательский интерфейс и поддержка кодировки юникод

Как Клиент так и Хост обладают возможностью смены языка пользовательского интерфейса.

Поддержка не ограниченного числа одновременных соединений

·Клиент может соединяться одновременно с несколькими серверами.

·Хост может принимать соединение сразу от нескольких клиентов.

·Режим и число соединений могут быть любыми.

Наличие множества режимов подключения

·Просмотр экрана и управление удаленным компьютером.

·Передача файлов.

·Выключение/перезагрузка.

·Удаленный реестр.

·Wake On Lan.

·Удаленный запуск программ.

·Терминал.

·Диспетчер удаленных процессов, окон и служб.

·Диспетчер устройств.

·Чат.

·Соединение по протоколу MS RDP.

·Запись экрана по расписанию.

·Отправка простых текстовых сообщений.


Системные требования

К аппаратному обеспечению компьютера особых требований нет. RMS успешно функционирует даже на компьютерах поколения Pentium Duo.

Требования к операционным системам

Клиент

Операционные системы

Microsoft Windows 11/10/8/7/Vista/XP/2003/2008/2012/2016/2019/2022.

Linux: Ubuntu 16+, Astra Linux "Орел", ALT Linux 8 и новее.

macOS 10.12 Sierra и новее.

Мобильные платформы: iOS и Android.

Хост

Работает под операционными системами Microsoft Windows 11/10/8/7/Vista/XP/2003/2008/2012/2016/2019/2022.

Сервер

Работает под операционными системами Microsoft Windows x64 - 11/10/8/7/Vista/2008/2012/2016/2019/2022.


Перед установкой

Перед тем как устанавливать новую версию программы:

·Деинсталлируйте предыдущую версию программы.

·Перезагрузите компьютер.

Внимание!

Для установки программы на ОС 11/10/8/7/Vista/XP/2003/2008/2012/2016/2019/2022 пользователь должен иметь права администратора.


Конфигуратор дистрибутива

Конфигуратор дистрибутива позволяет создавать свои собственные дистрибутивы Хоста с уже предустановленными настройками. Что весьма удобно при массовом развертывании серверов, в т.ч. с помощью удаленной установки.

MSI Конфигуратор

Просто укажите путь к MSI-файлу дистрибутива, который нужно настроить и нажмите "Конфигурировать". Появится стандартный интерфейс настроек сервера. Укажите нужные параметры и закройте окно настроек сервера. Все - дистрибутив готов.


Установка RMS

Инструкция по установке

·Распакуйте zip-архив, который содержит внутри два exe-файла: rms.host.XXX.exe и rms.viewer.XXX.exe, где XXX номер версии программы.

·Запустите rms.host.XXX.exe если хотите установить Хост или rms.viewer.XXX.exe — если Клиент.

·Следуйте инструкциям программы установки.

·Во время установки Хоста появится диалоговое окно настройки параметров безопасности, где вы можете установить пароль доступа или открыть окно с более продвинутыми настройками безопасности.

·Установка завершена.

Внимание!

Хост при установке автоматически интегрируется в стандартный брандмауэр 11/10/8/7/Vista/XP/2003/2008/2012/2016/2019/2022, но, тем не менее, если по какой-либо причине во время установки брандмауэр был выключен, проверьте, чтобы Хост был добавлен в список программ-исключений.


Установка без инсталлятора

Установка Клиента вручную

Клиент не требует специальной инсталляции. Для начала, установите Клиент на локальном компьютере из официального дистрибутива. Затем скопируйте все файлы и каталоги из папки "C:\Program Files\Remote Manipulator System - Viewer" (по умолчанию) в любую новую папку (например, "viewer"). Все - новая копия Клиента готова к работе.

Деинсталляции Клиент тоже не требует, просто удалите скопированные ранее файлы.

Как установить Хост вручную?

Инсталляцию Хоста можно условно разделить на два этапа: установку программы и установку настроек программы.

Установка программы

·Установите Хост на локальном компьютере из официального дистрибутива.

·Создайте новый каталог (например, "host").

·Скопируйте в новый каталог "host" все папки и файлы из каталога "C:\Program Files\Remote Manipulator System - Host" (по умолчанию).

·Скопируйте созданную директорию "host" в локальный каталог на удаленном компьютере, где нужно установить сервер.

·Выполните из командной строки команду rutserv.exe /silentinstall.

·Для того, чтобы интегрировать сервер с системным брандмауэром Windows необходимо выполнить из командной строки rutserv.exe /firewall.

Внимание!

Интерпретатор командной строки должен быть запущен от имени пользователя с правами администратора.

Установка настроек

Все настройки сервера (порт, привязка к сетевому интерфейсу и другие) хранятся в системном реестре. Вы можете скопировать эти настройки с одного компьютера на другой.

·Запустите стандартный редактор реестра Windows (c:\windows\regedit.exe).

·Экспортируйте раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\TektonIT\RMS Host\Host\Parameters в файл, например settings.reg.

·На машине, где нужно установить Хост выполните команду regedit.exe /s путь_к_файлу\settings.reg

Пример cmd-скрипта, осуществаляющего установку R-Server

net use x: \\server\c

mkdir "c:\windows\system32\rserver"

copy "x:\server\*.*" "c:\windows\system32\rserver\*.*"

regedit.exe /s c:\windows\system32\rserver\settings.reg

ping 127.0.0.1

c:\windows\system32\rserver\rutserv.exe /silentinstall

c:\windows\system32\rserver\rutserv.exe /firewall

c:\windows\system32\rserver\rutserv.exe /start

net use x: /delete

Деинсталляция Хоста

·Остановите Хост запустив rutserv.exe с ключом /stop.

·Запустите rutserv.exe с ключом /silentuninstall, чтобы деинсталлировать системную службу.

·Перезагрузите компьютер.

·Удалите файлы.

Дополнительные параметры командной строки для запуска rutserv.exe

·/silentinstall — установить службу.

·/silentuninstall — деинсталлировать службу.

·/firewall — интегрировать с системным файрволлом Windows.

·/start — запустить сервер.

·/stop — остановить сервер.

·/config — открыть окно настроек.


Удаленная установка средствами RMS

Для открытия окна удаленной установки в главном окне Клиента выделите одно или несколько соединений, на которые необходимо установить или обновить Хост, щелкните правой кнопкой мыши и в контекстном меню выберите пункт "Удаленная установка/удаление/запуск".

Удаленная установка Хоста доступна в двух режимах:

·С использованием "Системы безопасности Windows NT". При этом необходимо знать пароль администратора, и, внимание, пароль не должен быть пустым! Еще одно требование — в ОС Windows XP необходимо отключить т.н. "Простой общий доступ к файлам", это можно сделать так. Панель управления -> Свойства папки -> Вид. Убрать флажок с элемента "Использовать простой общий доступ к файлам" (Windows XP). Рекомендации по установке для ОС Windows 7/Vista и новее смотрите ниже в этом разделе.

·С использованием системы безопасности RMS. Для этого нужно, чтобы на сервере уже была запущена версия RMS не ниже 4.3, и разрешен доступ к этому серверу встроенной политикой безопасности Remote Manipulator System. Этот метод удаленной установки удобен для обновления уже установленной версии RMS. Работает на всех ОС, которые поддерживает RMS.

Окно удаленной установки

Окно удаленной установки

Рекомендации по совместимости удаленной установки с Windows 11/11/8/7/Vista.

Внимание!

Если компьютер, на которые необходимо установить сервер находится в домене, то указанные ниже рекомендации можно проигнорировать.

Для функционирования удаленной установки на компьютере, где будет установлен сервер необходимо:

·Отменить UAC (User Account Control) для сетевых подключений, это можно сделать, создав DWORD параметр LocalAccountTokenFilterPolicy в ветке реестра HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system\ это можно автоматизировать, создав reg-файл с нужными настройками. Содержимое reg-файла указано ниже.

Содержимое reg-файла, который отключает UAC для сетевых подключений:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]

"LocalAccountTokenFilterPolicy"=dword:00000001


Процесс установки

Дистрибутив Хоста поставляется в виде msi-файла, данные которого использует системный инсталлятор Windows. Это позволяет автоматически устанавливать Хост в доменной сети, при помощи групповой политики безопасности серверных ОС Windows 2008/2012/2016/2019/2022.

Процесс установки подразделяется на два основных этапа:

·Настройка msi-дистрибутива Хоста.

·Установка дистрибутива Хоста через групповые политики безопасности.


Инсталляция MSI дистрибутива

Для установки MSI дистрибутива на все компьютеры домена можно воспользоваться функцией установки программы, доступной через групповые политики безопасности.

·Запустите оснастку "Active Directory - пользователи и компьютеры", выберите в контекстном меню пункт "Свойства" для домена, в котором необходимо произвести установку.

AD - свойства домена

AD - свойства домена

·Если Вы хотите установить RMS только на определенные компьютеры в сети — создайте другой узел, в который будут включены нужные компьютеры.

·Откройте редактирование объекта групповой политики безопасности.

Изменить параметры групповой политики

Изменить параметры групповой политики

·Убедитесь, что включена политика "Всегда ожидать инициализации сети при загрузке и входе в систему", находящаяся в разделе "Конфигурация компьютера -> Административные шаблоны -> Система -> Вход в систему".

Ожидать инициализацию сети

Ожидать инициализацию сети

·Добавьте MSI дистрибутив в список программ для инсталляции в домене. Для этого в контекстном меню объекта "Конфигурация компьютера -> Конфигурация программ -> Установка программ" выберите пункт "Создать -> Пакет".

Создать пакет установки

Создать пакет установки

·Укажите для "RMSserver.msi" пункт "Особый".

Особый метод развертывания пакета

Особый метод развертывания пакета

·Подготовка пакета завершена. Убедитесь, что появилась строка "Remote Manipulator System - Server".

MSI пакет назначен

MSI пакет назначен

Внимание!

R-Server с назначенными настройками будет инсталлирован на все рабочие станции домена после ближайшей перезагрузки или двух.


Главное окно RMS-Viewer

Navigation: Использование RMS Удаленный доступ >

Return to chapter overview

Главное окно R-Viewer

Основные элементы:

Главное окно RMan-Viewer

Главное окно RMan-Viewer

1.Главное меню.

2.Панель инструментов.

3.Список соединений (удаленных компьютеров).

4.Дерево групп соединений.

5.Список режимов соединения.

6.Эскиз удаленного рабочего стола.

7.Переключатель между списком соединений и картой топологии сети.

8.Вызов окна настройки списка соединений.

9.Ползунок изменения размеров эскизов удаленных экранов.

10. Дополнительная информация о выделенном соединении.

Панель инструментов:

Панель инструментов главного окна

Панель инструментов главного окна

1.Запустить выбранное соединение в текущем режиме.

2.Добавить новое соединение.

3.Удалить выбранные соединения.

4.Обновить статус соединений, которые отображаются в данный момент в списке.

5.Повторная авторизация видимых соединений.

6.Обновить эскизы подключенных соединений.

7.Автоматический поиск удаленных R-Server в сети.

8.Запуск текстового чата.

9.Запуск удаленного обновления для соединений с устаревшими версиями R-Server.


Быстрый старт

Убедитесь, что на удаленном компьютере запущен R-Server и вам известен IP-адрес этого компьютера.

Алгоритм действий:

·В главном окне R-Viewer'а нажмите <Ins>, чтобы добавить новое соединение. В появившемся окне укажите название этого соединения и IP-адрес (пример: 192.168.0.1), DNS (NetBIOS) имя (пример: comp1.corporation.com) или Internet-ID идентификатор. Нажмите "OK".

Создание нового соединения

Создание нового соединения

·В главном окне R-Viewer'а вы увидите только что созданное соединение. Выберите это соединение и нажмите <Enter>.

·Если на удаленном компьютере установлена защита паролем, то появится окно для ввода этого пароля. Флажок "Сохранить пароль" означает, что при следующей попытке авторизоваться на сервере не будет необходимости вводить пароль заново, программа подставит его автоматически. Флажок "Авто-логин" означает, что при следующем запуске программы, процедура авторизации будет произведена автоматически. Данная функция будет работать только в случае, если установлен еще и флажок "Сохранить пароль".

Введите пароль

·Если на удаленном компьютере установлена защита системой безопасности Windows, то появится окно ввода атрибутов авторизации.

·Заполните форму и нажмите "OK".


Режимы соединения

Remote Manipulator System позволяет работать с серверами в нескольких режимах соединения одновременно.

Режимы соединения

·Управление. В этом режиме вы можете просматривать экран удаленного компьютера и управлять им клавиатурой и мышью.

·Просмотр. В этом режиме вы можете только просматривать экран удаленного компьютера.

·Передача файлов. Данный режим позволяет осуществлять основные файловые операции (копирование, перемещение, удаление, запуск) между удаленным компьютером и локальным.

·Wake On LAN. Эта функция позволяет удаленно включать выбранный компьютер, если данная возможность включена в настройках этого компьютера и R-Viewer'у известен его MAC-адрес.

·Выключение. С помощью этого режима соединения вы можете осуществлять все основные операции управления питанием удаленного компьютера, такие как выключение, перезагрузка, блокировка и остановка сеанса.

·Диспетчер задач. Данный режим позволяет просматривать и управлять процессами, окнами и службами удаленного компьютера.

·Запуск программ. С помощью этого режима вы можете запускать приложения на удаленном компьютере.

·Терминал. Этот режим позволяет получить полноценный доступ к командной строке удаленного компьютера.

· Диспетчер устройств. Позволяет просматривать и собирать подробную информацию об аппаратном и программном обеспечении удаленных машин.

· RDP. Подключение к удаленному рабочему столу, используя протокол и технологию Remote Desktop Protocol компании Microsoft Corporation.

· Текстовый чат. Данный режим позволяет общаться двум и более пользователям с помощью текстовых сообщений.

· Запись экрана. Режим "Запись экрана" позволяет следить за действиями пользователя полностью автономно от R-Viewer.

· Текстовое сообщение. Позволяет отправить простое текстовое сообщение на удаленный компьютер.


Управление и просмотр

Данный режим позволяет просматривать экран удаленного компьютера. При этом форма и положение курсора удаленного компьютера тоже передаются в окно просмотра экрана. Так же в этом режиме возможно включить перехват звука удаленного компьютера, т.о. вы на локальном компьютере будете слышать все то, что воспроизводится на удаленном компьютере.

Для доступа к настройкам соединения в режиме просмотра/управления нажмите <Ctrl>+F12.

Доступ ко многим функциям, доступным для данного режима осуществляется через системное меню данного окна.

Удаленное управление

Режим просмотра удаленного экрана

·Оконный. Экран удаленного компьютера отображается в отдельном окне в натуральную величину. Если размер окна меньше размера экрана удаленного компьютера, то при приближении указателя мыши к границе окна, картинка удаленного экрана перемещается в соответствующую сторону.

·Полноэкранный. Изображение удаленного экрана занимает весь экран локального компьютера. При этом, если разрешение локального и удаленного компьютера различны, изображение удаленного экрана будет соответствующим образом пропорционально от масштабирован.

·Сжатый (оконный с масштабированием). Экран удаленного компьютера отображается полностью в отмасштабированом виде в отдельном окне.

Перетаскивание файлов и каталогов (Drag and Drop)

Данный функционал позволяет перетаскивать файлы и каталоги непосредственно на удаленный компьютер и из удаленного компьютера. Просто выделите нужный файл на локальном компьютере и перетащите его на нужную папку, рабочий стол или другой объект на удаленном компьютере. Так же поддерживается обратное перетаскивание, т.е. можно перетащить нужный файл или каталог с удаленного компьютера на локальный.

Цветовой формат изображения, передаваемого с удаленного компьютера

·24 бита (более 16 миллионов цветов).

·16 бит (65 тысяч цветов).

·15 бит (32 тысячи цветов).

·8 бит (256 цветов).

Нагрузка на CPU

С помощью этой настройки вы можете менять нагрузку на CPU сервером. Регулируя этот параметр в совокупности с режимом работы сети (обычный, экономичный) можно достичь оптимальных характеристик производительности программы для самых различных сетей и компьютеров.

·Высокая. Данный режим обеспечит наилучший результат работы RMS вы быстрых сетях. Рекомендуется использовать с обычным режимом работы сети.

·Средняя. Режим по-умолчанию. Подходит для большинства локальных и быстрых xDSL-каналов.

·Низкая. Данный режим подойдет если на сервере слабый CPU или выполняются критичные задачи.

·FPS. Это особый режим, в котором есть возможность жестко ограничить FPS (количество передаваемых кадров в секунду).

Режим работы сети

·Стандартный. Этот режим подходит для быстрых сетей и обеспечивает максимальную скорость работы программы.

·Экономичный. В данном режиме, с помощью специальной технологии, RMS минимизирует нагрузку на сеть до 10 раз, по сравнению с обычным режимом, что позволяет комфортно работать даже через медленные сетевые каналы.


Передача файлов

Данный режим позволяет осуществлять различные файловые операции между R-Viewer и R-Server.

Файловый менеджер

Основные файловые операции

·Копирование файлов и каталогов между локальным и удаленным компьютером.

·Перемещение файлов и каталогов между локальным и удаленным компьютером.

·Переименование файлов и каталогов.

·Создание новых каталогов.

·Локальный и удаленный запуск приложений.

Все эти операции легко осуществлять с помощью удобного и интуитивно-понятного интерфейса файлового менеджера с поддержкой горячих клавиш и возможностью перетаскивания файлов непосредственно в Windows.

Поддержка системного перетаскивания файлов и папок (Drag and Drop)

Файловый менеджер поддерживает перетаскивание файлов и каталогов непосредственно в Windows и другие программы, поддерживающие стандартный Drag and Drop. Т.е. можно выделить файлы и каталоги (как локальные, так и удаленные) в файловом менеджере RMS и перетащить их в нужную папку, рабочий стол или программу на локальном компьютере. Так же поддерживается обратная операция - перетаскивание файлов из Windows в файловый менеджер.

Интеллектуальная докачка файлов

Поддержка этой функции всегда включена при передачи файлов через Remote Manipulator System. Интеллектуальная докачка отличается от обычной тем, что её принцип работы основан не только на определении размера докачиваемой части файла, но и на определении содержимого файла. Т.е. даже при обычной замене файла (к примеру, если файл уже существует), RMS будет перезаписывать не весь файл целиком, а только его измененные части.


Wake On LAN

Эта функция позволяет удаленно включать компьютер. Чтобы функция работала, необходимо, чтобы Хост находился в одной подсети с Клиентом. Также необходимо, чтобы компьютер с сервером аппаратно поддерживал функцию Wake On Lan и была она включена в настройках BIOS.

Wake On Lan

Wake On Lan

Внимание!

Для того, чтобы использовать эту функцию Клиенту должен быть известен MAC-адрес сервера. Этот адрес автоматически определяется при авторизации соединения и сохраняется в настройках. Таким образом, Wake-On-Lan будет работать только в том случае, если было произведена хотя бы одна авторизация к удаленному серверу.


Отключение

Данный режим предназначен для управления базовыми функциями питания удаленного компьютера.

Управление питанием

Функции

·Перезагрузка.

·Выключение.

·Остановка сеанса пользователя.

·Блокировка компьютера.


Диспетчер задач

С помощью удаленного диспетчера задач вы можете управлять процессами, окнами и службами удаленного компьютера. В окне диспетчера задач можно наблюдать 4 вкладки: процессы, окна, службы и пользователи. В каждой из них отображается список соответствующих объектов удаленной машины.

Диспетчер задач

Действия, осуществляемые удаленным диспетчером задач

·Просмотр списка процессов (включая полный путь к исполняемому файлу, нагрузку на центральный процессор и имя пользователя, запустившего процесс), остановка процесса, простой доступ к функции удаленного запуска процессов.

·Просмотр списка окон, с указанием активного в данный момент окна, закрытие выбранного окна.

·Просмотр списка служб (сервисов), запуск и остановка указанной службы.

·Просмотр списка активных терминальных сессий. Управление терминальными сессиями.


Реестр

Модуль "Удаленный реестр" представляет собой практически полный аналог системного редактора реестра, но с тем отличием, что работает с реестром удаленного компьютера.

Редактор реестра


Запуск программ

Этот режим предоставляет возможность запускать приложения на удаленном компьютере. Есть возможность указывать дополнительные параметры запуска. Работает аналогично системной программе "Выполнить".

Удаленный запуск


Терминал

Режим "Терминал" позволяет получить полноценный доступ к командной строке удаленного компьютера. Ввод команд и запуск программ в окне "Терминал" производится точно так же, как в командной строке системной утилиты "cmd".

Терминал

Возможна работа как от имени системной учетной записи, так и от имени текущего интерактивного пользователя.


Диспетчер устройств

С помощью диспетчера устройств можно просматривать и собирать подробную информацию об аппаратном и программном обеспечении удаленных машин. Имеется возможность автоматического составления отчетов по указанным компьютерам, с возможностью экспорта в HTML или XML формате.

Диспетчер устройств

Для того, чтобы получить информацию по интересующим компьютерам:

·Выделите интересующие соединения в списке соединений главного окна R-Viewer.

·Запустите "Диспетчер устройств".

·Поставьте флажок напротив названий нужных соединений в списке "Соединения" окна диспетчера устройств.

·Нажмите "Запросить информацию". Дождитесь окончания операции сбора данных.

·В меню "Файл" есть команды, позволяющие сохранять и экспортировать полученные отчеты.


RDP

Подключение к удаленному рабочему столу, используя протокол и технологию Remote Desktop Protocol компании Microsoft Corporation. Для функционирования этого режима не обязательно, чтобы на удаленной машине был установлен R-Server. Достаточно, чтобы был разрешен доступ к встроенной системной утилите управления рабочим столом.

Настройки RDP не пересекаются со стандартными настройками соединений Remote Manipulator System. Для доступа к настройкам RDP щелкните правой кнопкой мыши по нужному соединения и в контекстном меню выберите "Настройки RDP...".


Текстовый чат

Данный режим позволяет общаться двум и более пользователям с помощью текстовых сообщений.

Текстовый чат

В текстовом чате Remote Manipulator System есть два типа клиентов (пользователей): администраторы - это пользователи, общающийся через R-Viewer и обычные пользователи, общающиеся через R-Server. Инициировать сеанс связи с другими удаленными пользователями может только администратор.

Сообщения можно отсылать как в общий канал - тогда его увидят все пользователи, так и в частном порядке, конкретному пользователю. Для отправки сообщения нажмите <Ctrl> + <Enter>, это аналогично нажатию кнопки "Отправить".

Основные возможности:

·Поддержка неограниченного числа пользователей.

·Приватный чат.

·Расширенное форматирование текста (выбор начертания и выравнивания, создание списков).

·Отправка файлов.

·Отправка изображений.


Запись экрана

Режим "Запись экрана" позволяет следить за действиями пользователя полностью автономно от R-Viewer. Т.е. администратор, с помощью удобного пользовательского интерфейса, может задать расписание, которое, если перевести на человеческий язык, выглядит так - "Делать снимок каждые 2 минуты, по рабочим дням с 8 утра до 5 вечера". В любой момент администратор может загрузить с сервера файл, в котором хранятся снимки экрана за какой-то конкретный день и посмотреть, с помощью специального плеера, что происходило на экране удаленного компьютера, к примеру, в 16:00. Так же имеется возможность защиты файлов с записями от удаления на сервере.

Итак, кому может понадобиться это? В первую очередь, администраторам и руководителям, так как это дает возможность контролировать работу самих пользователей, просмотрев дневной отчет с кадрами раз в 1 минуту, можно получить точную картину того, что происходило на экране удаленного компьютера на протяжении всего рабочего дня. Таким образом можно серьезно оптимизировать работу сотрудников, даже, когда администратора нет на рабочем месте.

Если на экране удаленного сервера, выводится какая-то статистическая информация (к примеру, нагрузка на CPU и т.д) то удобно будет использовать запись для учета нагрузки на протяжении суток, особенно в ночное время, что весьма важно при администрировании серверов. Если к компьютеру имеют общий доступ несколько пользователей, или не ограниченное их количество, то запись может быть полезна для контроля их действий.

Загрузчик

Окно загрузчика

В окне отображен список доступных для просмотра файлов, их размер, дата создания, расписание по которому создан файл и его тип. Файлы могут быть двух типов: локальные и удаленные, удаленные файлы находятся на сервере в каталоге "\Remote Manipulator System - Server\Record\", локальные файлы находятся на компьютере с R-Viewer в каталоге "C:\Documents and Settings\All Users\Application Data\Remote Manipulator Files\Record\" или "C:\ProgramData\Remote Manipulator Files\Record". Название файла можно поменять на любое другое, удобное для вас, но при этом расширение файла должно остаться прежним - ".rrf".

Чтобы запустить просмотр файла достаточно двойного щелчка по его имени в списке.

Для удобства, можно использовать фильтры по дате, по расписанию и по типу расположения файла.

Меню

·Настройки. Открывает окно настроек записи экрана. Здесь можно включить/выключить запись, установить интервал получения скриншотов и т.д.

·Просмотреть файл. Открывает окно просмотра выбранного файла, если он удаленный, то происходит его закачка по сети на R-Viewer.

·Загрузить файл. Программа копирует удаленный файл на локальный диск, после чего он появляется в списке локальных файлов.

·Обновить. Обновляет список локальных и удаленных файлов.

·Открыть файл. Появляется диалоговое окно, где можно выбрать любой другой ".rrf"-файл для просмотра.

·Удалить. Удаляет выбранный файл.

·Загрузить все файлы. Позволяет загрузить все удаленные файлы на локальный компьютер, кроме текущего файла, который используется для записи.

Окно настроек

Общие настройки

Окно настроек записи экрана

Окно настроек записи экрана

·Запись включена. Установите флажок, чтобы включить запись экрана.

·Интервал снимков. Интервал, через который будут производиться снимки экрана, не рекомендуется устанавливать слишком маленький интервал, к примеру, в 1 секунду, т.к это может создать большую нагрузку на процессор и быстро израсходовать свободное пространство на жестком диске.

·Защищать файлы на сервере. Защищает записи от удаления их пользователями на удаленном сервере.

·Указывать дату и время на кадрах. Дата и время создания кадра будут отображены на самом снимке.

Расписания

Настройка расписаний

Здесь вы можете настроить расписание, по-которому будет происходить запись экрана, по-умолчанию создается одно активное расписание.

Для удобства можно создать несколько расписаний.

·Активно. Включает/выключает расписание.

·Интервал времени суток. Устанавливает время начала и окончания записи.

·Интервал дат. Устанавливает дату начала и окончания записи

·Дни недели. Устанавливает дни недели, по которым будет работать запись экрана

Параметры

Так как запись экрана может быть активна продолжительное время, файлы будут занимать много места на диске, чтобы избежать проблем можно настроить степень сжатие и ограничение на размер создаваемых файлов.

·Качество сжатия. Устанавливает степень сжатия по алгоритму JPEG.

·Масштаб. Уменьшает размер кадра пропорционально исходного.

·Тип сжатия. JPEG или PNG.

·Максимальный размер файла. Устанавливает ограничение на максимальный размер файла записи для удобства его передачи по сети и просмотра.

·Стереть файл после. Устанавливает срок активации авто-очистки файлов, начиная с момента их создания.

·Общий размер файлов. Устанавливает лимит на размер всех файлов с записями экрана на диске.

Параметры

Просмотрщик (плеер)

Плеер

Окно просмотрщика по функционалу похоже на простой видео плеер, с возможностью навигации по кадрам и их экспорта.

Меню файл

·Экспортировать текущий кадр. Сохраняет текущий просматриваемый снимок на диск.

·Экспортировать все кадры. Сохраняет все снимки данной записи на диск.

·Сохранить как. Позволяет сохранить весь файл со снимками на диск.

Навигация

Позволяет перемещаться по кадрам вперед и назад, а также в начало и в конце всех снимков, есть возможность перейти к нужному кадру по его номеру. Можно проигрывать снимки с заданным интервалом, а так же сжать (растянуть) изображение на все окно плеера.


Текстовое сообщение

Режим "Текстовое сообщение" позволяет отправить простое текстовое сообщение на удаленный компьютер. Сообщение будет отображено на экране удаленного компьютера, что привлечет внимание пользователя, сидящего за этим ним.


Ключи командной строки

Для R-Viewer

Основные ключи:

·/name:<название_соединения> — название соединения, для которого необходимо запустить определенный режим.

·/password:<пароль> — пароль для доступа к удаленному серверу. Если пароль не задан явно, то он берется из настроек соединения.

Режимы соединения:

·/FULLCONTROL — управление мышью и клавиатурой удаленного компьютера.

·/VIEWONLY — просмотр экрана удаленного компьютера.

·/FTP — файловый менеджер.

·/WEBCAMERA — удаленная камера.

·/SHUTDOWN — перезагрузка, выключение, выход пользователя и блокирование (уточняющие ключи: /RESTART, /POWEROFF, /SWITCHOFF, /LOCK) компьютера.

·/TASKMANAGER — диспетчер задач.

·/REMOTEEXECUTE — удаленный запуск программ (уточняющие ключи: /FILENAME:<название_программы>, /HIDDEN).

·/TELNET — терминал.

·/REGISTRY — реестр.

·/DEVICEMANAGER — диспетчер устройств.

·/RDP — подключение через Microsoft Remote Desktop Protocol.

·/CHAT — текстовый чат.

·/SCREENRECORD — запись экрана по расписанию.

·/SEND_MESSAGE — отправка простого текстового сообщения.

·/OVERLAY — видео оверлей.

Примеры:

Подключение соединения с названием "XP" в режиме управления мышью и клавиатурой

rutview.exe /name:XP /password:123456789 /fullcontrol

Запуск калькулятора, пароль берется из настроек (опция "Сохранять пароль" должна быть включена)

rutview.exe /name:XP /remoteexecute /filename:calc.exe

Для Хоста

·/silentinstall — установить службу.

·/silentuninstall — деинсталлировать службу.

·/firewall — интегрировать с системным файрволлом Windows.

·/start — запустить Хост.

·/stop — остановить Хост.

·/config — открыть окно настроек Хоста.

Внимание!

Команды Хоста нужно выполнять только от имени администратора.


Обратное соединение

Функция "Обратное соединение" (callback) позволяет серверу выступать инициатором сетевого соединения. Благодаря этому механизму можно осуществлять соединение даже с сервером, который находится за сетевым экраном или же, если не известен его IP-адрес.

Для того, чтобы настроить обратное соединение, необходимо определенным образом сконфигурировать R-Viewer и сервер.

Настройка R-Server

Сервер может устанавливать любое число обратных соединений. Непосредственно подключение может осуществляется как вручную, так и автоматически, через регулируемый интервал времени.

Алгоритм создания и подключения обратного соединения на сервере

·Убедитесь, что разрешен механизм обратных соединений.

·Щелкните правой кнопкой мыши по иконке R-Server рядом с системными часами.

·В контекстном меню выберите пункт "Обратное соединение…" — откроется окно управления обратными соединениями.

Контекстное меню сервера

Контекстное меню сервера

·Нажмите на панели инструментов "Добавить обратное соединение" — откроется окно с параметрами нового соединения.

·Укажите IP-адрес R-Viewer'а и текст приглашения, который увидит удаленный администратор, нажмите OK.

·Выберите созданное соединение в списке и нажмите "Установить соединение".

·После того, как администратор на R-Viewer'е примет подтвердит обратное соединение, он сможет подсоединиться к сконфигурированному R-Server'у.

Настройка R-Viewer

Для того, чтобы принимать входящие соединения в настройках R-Viewer необходимо включить соответствующую опцию.

·Откройте окно настроек R-Viewer ("Инструменты -> Настройки").

·В появившемся окне перейдите во вкладку "Обратное соединение".

·Установите флажок "Разрешить входящие соединения" и нажмите "OK".

Настройка обратных соединений

Настройка обратных соединений

В настройках обратных соединений так же можно указать порт, на который будут приниматься соединения и отредактировать черный и белый список IP адресов и диапазонов IP-адресов. Для обратных соединений на R-Viewer существует две политики безопасности: на основе черного списка и на основе белого списка.

·Политика безопасности на основе черного списка разрешает принимать соединения от всех компьютеров, кроме тех, IP-адреса которых находятся в черном списке.

·Политика безопасности на основе белого списка запрещает принимать соединения от всех компьютеров, кроме тех, IP-адреса которых находятся в белом списке.

Внимание!

Для того, чтобы R-Viewer принимал обратные соединения сервера необходимо, чтобы настроить политику безопасности файрволла таким образом, чтобы R-Viewer мог принимать входящие сетевые соединения. Чаще всего достаточно добавить RMSViewer.exe в список исключений файрволла.


Поиск серверов

R-Viewer обладает встроенной системой поиска R-Server'ов в сети. Поиск осуществляется по заданным диапазонам IP-адресов, таким образом есть возможность настраивать зоны сканирования. Поиск осуществляется в многопоточном режиме, что позволяет сканировать большие сегменты сети за очень короткий промежуток времени. Имеется возможность указывать число потоков сканирования.

Поиск серверов

После завершения сканирования сети в списке можно посмотреть, на каких компьютерах установлен R-Server, а на каких нет.

Компьютер выключен.

Компьютер включен, R-Server не установлен.

Компьютер включен, R-Server установлен.

Найденные компьютеры можно, нажатием одной кнопки, добавить в текущий список соединений.


Портативная версия R-Viewer

R-Viewer может работать в портативном режиме. Этот режим отличается от обычного тем, что все настройки программа хранит в том же каталоге, где находится сама. Портативный режим позволяет запускать R-Viewer с flash-носителей и не требует специальной установки.

Как создать портативную версию R-Viewer?

·Если требуется, создайте на flash-диске директорию, в которой будет находится R-Viewer.

·Скопируйте в созданную директорию все файлы и каталоги из директории, в которую RMS установлен обычным образом.

·И последний самый важный шаг — в созданной директории с портативной версий R-Viewer создайте пустой файл license.txt.

·Все, теперь программу можно запускать со съемного носителя.

Внимание!

Для функционирования портативной версии R-Viewer, необходимо, чтобы была возможность записи на носитель, откуда программа запускается.


Безопасность

Remote Manipulator System спроектирован с учетом современных стандартов и требований безопасности на всех уровнях. Все данные, передаваемые по сети, шифруются, эту функцию нельзя отключить. Используется криптографический протокол TLS 1.2.

RMS поддерживает две системы авторизации: защита паролем и защита на базе Active Directory. Настройки R-Server хранятся в системном реестре Windows, доступ к ним ограничен всем, кроме пользователей с правами администратора. Так же есть возможность поставить пароль на доступ к настройкам сервера даже для администраторов.

Имеется гибкая система разграничения сетевого доступа к серверу: привязка к одному конкретному сетевому интерфейсу, запрет доступа по IP-адресу или диапазону IP-адресов, защита от подбора пароля и DoS-атак.


Windows XP & простой общий доступ к файлам

Если на удаленном компьютере установлена операционная система Windows XP, рекомендуется отключить "простой общий доступ к файлам". К сожалению в Home-редакции Windows XP нельзя отключить эту опцию, поэтому вы не сможете использовать безопасность на базе Windows NT и удаленную установку с использованием безопасности Windows NT, для компьютеров под управлением Windows XP Home.

Так же для функционирования удаленной установки с использованием системы безопасности Windows NT, на удаленном компьютере необходимо установить пароль для учетной записи администратора и использовать именно эту учетную запись при удаленной установки R-Server. Если пароль пуст, то программа удаленной установки R-Server'a не сможет авторизоваться на удаленном компьютере.

Как запретить "Простой общий доступ к файлам" в Windows XP Professional?

·Откройте окно "Мой компьютер".

·Выберите в главном меню "Сервис -> Свойства папки".

·Откроется окно "Свойства папки", перейдите во вкладку "Вид".

Простой общий доступ к файлам

Простой общий доступ к файлам

·Уберите флажок "Использовать простой общий доступ к файлам".

·Нажмите "OK".


Рекомендации по настройке производительности

RMS спроектирован таким образом, что при правильной настройке позволяет добиться быстрой скорости работы, как в хороших сетях, так и в узких Internet-каналах, как на мощных мультипроцессорных серверах, так и на слабых офисных рабочих станциях. Чтобы оптимально настроить производительность программы нужно, в первую очередь, знать все плюсы и минусы сети, в которой RMS будет использоваться и рабочих станциях, на которых будет установлен.

Настройки, влияющие на производительность

·Режим работы сети (стандартный, экономичный). Экономичный режим позволяет, благодаря специальной технологии передачи изображения, минимизировать нагрузку на сеть до 10 раз, по сравнению со стандартным режимом. В быстрых сетях, где экономия трафика не критична, использование данного режима может замедлить работу программы, по сравнению со стандартным режимом.

·Глубина цвета изображения удаленного экрана, передаваемого по сети (24, 16, 15 или 8 бит). Чем больше глубина цвета, тем реалистичнее изображение, но и тем больше должна быть пропускная способность сети, для комфортной работы.

·Режим нагрузки на CPU (низкий, нормальный, высокий, FPS). Данный параметр определяет, сколько процессорного времени будет тратиться на обработку изображения R-Server’ом. На слабых рабочих станциях рекомендуем поставить низкую нагрузку. Так же, даже если рабочая станция обладает мощным процессором и графической системой, но сеть, через которую работает R-Server медленная и с малой пропускной способностью – не рекомендуем устанавливать высокую нагрузку на CPU, т.к. это может привести к перегрузке сети. Интересных результатов оптимизации можно добиться, экспериментируя с режимом FPS, в данном режиме есть возможность строго указать ограничение на количество передаваемых кадров в секунду.

Выше перечислены 3 основные характеристики, влияющие на производительность работы системы удаленного администрирования. Настраивать эти характеристики рекомендуется, исходя из конфигурации имеющейся сети.

Так же для увеличения скорости работы в медленных сетях рекомендуется отключить обои рабочего стола (см. вкладку "Расширенные опции" на панеле настроек). В Windows 7/Vista можно значительно снизить нагрузку на CPU, отключив графическую оболочку Aero.

Несколько типовых конфигураций сети

Быстрая локальная сеть и мощные рабочие станции

В данном случае слабых звеньев нет, поэтому смело можно поставить высокую нагрузку на CPU и стандартный режим работы. Глубина цвета 16 или 24 бита.

Офисная сеть с современными офисными рабочими станциями

Все настройки следует оставить по-умолчанию, т.е. стандартный режим работы сети и средняя нагрузка на CPU. Глубина цвета 16 бит.

Быстрый Internet-канал со слабыми рабочими станциями (WAN, xDSL нового поколения)

Здесь уместно либо ограничить FPS 20-25 кадрами в секунду, либо поставить низкую нагрузку на CPU, использовать стандартный режим работы и глубину цвета такую же, как на рабочем столе компьютера с R-Server’ом.

Медленный Internet-канал (EDGE, GPRS)

Только экономичный режим работы сети. Нагрузку на CPU луче подобрать экспериментальным путем. Если сеть очень медленная, то рекомендуем ограничить FPS 5 — 10 кадрами в секунду. В некоторых случаях хорошего эффекта можно достичь, установив высокую нагрузку на CPU. Глубина цвета 8-16 бит.


Вопрос-ответ

Общие вопросы

В: Почему мигает курсор на удаленном компьютере?

O: На R-Viewer включена опция “Перехватывать полупрозрачные окна”.

В: При работе на удаленном компьютере на панельке пуск появляются лишние кнопочки с надписью "RMSserver", почему?

O: При включении блокировки экрана удаленного компьютера (опция “Блокировать экран сервера”), проявляется данный эффект.

В: В диспетчере задач наблюдается несколько процессов RMS, что это за процессы?

O: Это основные модули R-Server, необходимые для полноценной работы программы в системе.

В: Программа не может захватить оверлейное видео.

O: Проверьте включена ли опция перехвата оверлейного видео в настройках сервера. Если включена значит программе просто не удается захватить и распознать видео. Если оверлейное видео не перехватывается, но в режим "Просмотр удаленного экрана" оно отображается, это значит, что видео не является оверлейным.

В: Почему такая высокая нагрузка на процессора - около 100% ?

O:

·Попробуйте отключить опцию на сервере “Перехватывать оверлейное видео”.

·Поэкспериментируйте с настройками производительности “Загрузка CPU”, можно установить параметр FPS 1-5 или низкий уровень нагрузки.

·Проверьте включено ли аппаратное ускорение оборудования.

·В системах Vista, 2008, Windows 7, при включенной оболочке Aero наблюдается повышенная нагрузка на процессор.

·На многомониторных системах при одновременной просмотре всех рабочих столов, нагрузка на процессор возрастает.

В: Не могу соединиться с удаленным сервером.

O:

·Проверьте, установлен ли и запущен R-Server на удаленном компьютере, также проверьте версию R-Viewer и R-Server - они должны одинаковыми.

·Проверьте, PING до компьютера, к которому желаете соединиться, а так же добавьте R-Server и его компоненты в список исключений стандартного и других брандмауэров или файрволлов.

·При подключении через Интернет возможно нужно правильно настроить port mapping.

В: Не работает удаленная установка.

O:

·Если установка производится вне домена, то убедитесь, что отключен простой общий доступ к файлам.

·Пользователь от имени которого производится удаленная установка должен обладать правами администратора.

В: Можно ли скрыть значок R-Server из трея (область на панеле задач возле часов).

O: На данный момент скрывать иконку можно. Но мы не гарантируем, что эта возможность останется в будущем.

В: Оптимизация программы для слабых сетей xDSL 64-128 кбит/c, что нужно сделать?

O:

·Включите "Экономичный режим".

·Уберите заставку на удаленном рабочем столе (такая опция есть в параметрах соединения), заставка скрывается автоматически при подключении.

·Можете поэкспериментировать с палитрой, к примеру, поставить 256 цветов.

В: На карте неправильно отображаются выделенные элементы карты.

O: Просто переключитесь с карты на список соединений и обратно или перезапустите R-Viewer.

В: Для чего нужна функция "Обратное соединение"?

O: Данная функция просто незаменима в том случае, если R-Viewer имеет белый IP, а сервер находится за NAT или с динамическим IP.

На сервере, если щелкнуть по иконке в трее правой кнопкой мыши, появится контекстное меню, где можно выбрать пункт "Обратные соединения". В появившемся окне добавляем нужный адрес R-Viewer и текст сообщения с приглашением. Потом выбираем обратное созданное соединение и щелкаем "Соединиться". Если все сделано правильно, на R-Viewer должно появиться приглашение на входящее соединение от сервера, его необходимо принять. Если соединение устанавливается впервые, то будет предложено, уже на R-Viewer, создать соединение для этого обратного режима.

Когда все создано - на R-Viewer стандартно авторизуем это соединение и работаем как обычно, в этом режиме работы все соединения инициирует сервер. Скорость работы в режиме обратного соединения может быть медленнее, чем при обычном режиме.

В: Сделал портативную версию R-Viewer, согласно инструкции, но список соединений не сохраняется. В чем причина?

O: Для функционирования портативной версии R-Viewer, необходимо, чтобы была возможность записи на носитель, откуда программа запускается.

Портативная версия не доступна в пробном режиме, т.о. её могут использовать только зарегистрированные пользователи. Как и в обычной версии просто добавьте приобретенный лицензионный ключ в менеджер лицензий.


Лицензионное соглашение (EULA)

REMOTE MANIPULATOR SYSTEM (RMS)

ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ КОНЕЧНОГО ПОЛЬЗОВАТЕЛЯ

1. Термины и определения

1.1. Программный продукт - система удаленного администрирования, мониторинга и управления «Remote Manipulator System» или «RMS Удаленный доступ», все ее компоненты, версии для различных платформ и операционных систем, а также любая документация по ее использованию.

1.2. Хост - компонент Программного продукта «Remote Manipulator System - Host».

1.3. Клиент - компонент Программного продукта «Remote Manipulator System - Viewer».

1.4. Сервер - компонент Программного продукта «Mini Internet-ID сервер».

1.5. Пользователь (Вы) - физическое или юридическое лицо, которое устанавливает и/или использует Программный продукт от своего лица или правомерно владеет копией Программного продукта.

1.6. Правообладатель - владелец исключительных имущественных и неимущественных прав на Программный продукт.

1.7. Сайт - сайт Программного продукта rmansys.ru.

1.8. Компьютер - операционная система, виртуальная машина или оборудование, включая рабочую станцию, сервер, мобильный телефон или планшетный компьютер, для работы на котором предназначен Программный продукт и/или на которое устанавливается Программный продукт и/или для которого используется Программный продукт.

1.9. Оператор - лицо, осуществляющее работу с модулем Клиент.

1.10. Лицензионный ключ - уникальный набор буквенно-цифровых символов, предназначенный для активации Программного продукта.

2. Предмет соглашения

Настоящее лицензионное соглашение (далее Соглашение) является юридическим документом, заключаемым между Правообладателем и Пользователем (Вами), правомерно владеющим экземпляром Программного продукта.

Устанавливая, копируя, загружая или иным образом используя Программный продукт, вы тем самым принимаете на себя условия настоящего Соглашения. Если вы не согласны с условиями настоящего Соглашения, вы не имеете права каким-либо образом использовать Программный продукт.

3.1. Предоставление Лицензии

3.1. Лицензия. Правообладатель предоставляет Вам неэксклюзивную и непередаваемую Лицензию хранить, загружать, устанавливать, выполнять и отображать («Использовать») указанную версию Программного продукта на указанном количестве Компьютеров, для которых программное обеспечение было разработано и на которых оно было первоначально установлено Вами, в соответствии с условиями настоящего Соглашения («Лицензия»), и Вы соглашаетесь и принимаете указанную Лицензию следующим образом:

3.1.1. Пробная Версия.

Если Вы получили, загрузили и/или установили пробную версию Программного продукта, Вы тем самым получили лицензию на пробную эксплуатацию Программного продукта, и Вы можете использовать его только в целях оценки и только в течение однократного испытательного периода в тридцать (30) дней, если не оговорено иное, начиная с даты первоначальной установки. Любое использование Программного продукта для других целей или дольше соответствующего испытательного периода строго запрещено, при условии, однако, что, учитывая указанные здесь ограничения, Вы можете копировать и распространять пробную версию Программного продукта без каких бы то ни было изменений любому третьему лицу в соответствии с данным Соглашением.

3.1.2. Коммерческое лицензирование.

После внесения оплаты за Лицензию и регистрации Программного продукта, Вам предоставляется неисключительная и непередаваемая лицензия установки и использования копии Программного продукта в течение Срока действия настоящего Соглашения, при условии внесения соответствующей оплаты и принятия Вами условий настоящего Соглашения. Дополнительно, индивидуальные условия лицензирования могут определять другие условия, сроки и ограничения использования Программы.

3.1.3. Классическая Лицензия.

Классическая Лицензия позволяет устанавливать модуль Клиент на любое количество Компьютеров, модуль Клиент может использоваться неограниченным числом Операторов одновременно.

Классическая Лицензия позволяет устанавливать модуль Хост на Компьютеры в количестве, указанном в Лицензионном Ключе.

3.1.4. Операторская Лицензия (далее Helpdesk).

Число одновременно работающих Операторов на Компьютерах с установленным модулем Клиент – согласно количеству лицензий, указанному в Лицензионном Ключе.

3.1.5. Неограниченная Лицензия.

Неограниченная Лицензия представляет собой Единичную Лицензию, которую можно использовать на неограниченном количестве Клиентов, Хостов и всех других компонентов Программного продукта, устанавливать на неограниченное количество Компьютеров, с которыми может одновременно работать неограниченное число пользователей.

3.1.6. Бесплатная Лицензия.

Бесплатная Лицензия позволяет устанавливать модуль Клиент на любое количество Компьютеров, модуль Клиент может использоваться неограниченным числом Операторов одновременно.

Бесплатная Лицензия позволяет устанавливать модуль Хост на Компьютеры в количестве 10 (десять) штук.

Бесплатная Лицензия предоставляется всем желающим полностью безвозмездно (бесплатно). При этом сохраняется возможность использовать данную лицензию в любых организациях, в т.ч. государственных и частных. Бесплатная Лицензия полностью бесплатна для физических и юридических лиц.

Максимальное количество Компьютеров, на которых можно использовать данную лицензию – 10 (десять).

Частное лицо, либо организация не имеет право использовать более одного Лицензионного Ключа с Бесплатной Лицензией.

Бесплатная Лицензия не может использоваться одновременно с какой-либо другой лицензий на Программный продукт, в том числе с другой Бесплатной Лицензией.

3.1.7. Лицензирование Сервера.

Сервер может быть бесплатно установлен и бесплатно использоваться на любом количестве Компьютеров, независимо от типа лицензии Программного продукта.

3.1.8. Классическая Коммерческая, Classic License, Enterprise License являются синонимами Классической Лицензии (п.3.1.3) и полностью равнозначны ей.

4. Права на Программу

Все исключительные авторские права на Программный продукт и документацию к нему в печатном или электронном виде принадлежат Правообладателю и защищены законодательством Российской Федерации и международными соглашениями.

5. Объем прав, предоставляемых настоящим Соглашением

5.1. Настоящее Соглашение предоставляет вам следующие права:

5.1.1. Право установить и использовать одну копию Хоста на одном компьютере.

5.1.2. Право изготовить копию Программного продукта при условии, что эта копия предназначена только для архивных целей и для замены правомерно приобретенного экземпляра в случаях, когда оригинал утерян, уничтожен или стал непригоден для использования. Данная копия не может быть использована для иных целей и должна быть уничтожена в случае, если владение экземпляром Программного продукта перестанет быть правомерным.

5.1.3. Вы можете передать Ваши права по настоящему Соглашению другому физическому или юридическому лицу на постоянной основе, при условии, что a) Вы также передаете это Соглашение, Программный продукт, все сопроводительные печатные материалы, и все другое программное обеспечение или оборудование, предустановленные или, являясь неотъемлемой частью Программного продукта, его сопутствующие, включая все копии, Обновления и предыдущие версии, такому физическому или юридическому лицу; b) Вы не сохраняете никаких копий, включая резервные копии и копии, хранящиеся на Компьютере; и c) получающая сторона принимает и соглашается со всеми условиями настоящего Соглашения и любыми другими условиями, на которых Вы законно приобрели лицензию на Программный продукт. Несмотря на предшествующее положение, Вы не можете передавать копии предварительного выпуска, или копии Программного продукта, созданные «не для перепродажи». Ни в каком случае Вы не имеете права разрешать третьим лицам извлекать выгоду из использования или функциональных возможностей Программного продукта через таймшерные договоры, договоры бюро услуг или другие соглашения, кроме как в той степени, в какой такое использование определено и предусмотрено в прайс-листе, заказе на товары или на упаковке Программного продукта.

5.1.4. Передавать Лицензию на Программный продукт, по условиям, изложенным в п. 5.1.3, разрешается не чаще одного раза в семь (7) календарных дней.

5.1.5. Право на пользование услугами бесплатной службы технической поддержки Правообладателя (по телефону или электронной почте).

5.1.6. Право на получение обновлений Программного продукта через интернет.

В течение Срока действия настоящего Соглашения Вы можете загружать обновления к Программе, в той степени, в которой Правообладатель публикует их на веб-странице или загружать их через другие интерактивные службы. Несмотря на любое указывающее обратное условие, содержащееся здесь, ничто в этом Соглашении не должно рассматриваться, как предоставление Вам каких бы то ни было прав или лицензий в отношении новых выпусков Программного продукта или предоставление Вам права требования на получение любого нового выпуска. Настоящее Соглашение не обязывает Правообладателя обеспечивать Вам предоставление каких-либо Обновлений.

5.1.7. Доступность сервера.

Для корректной работы Программного Продукта может быть необходима работа главного сервера Правообладателя. Правообладатель примет все необходимые меры для обеспечения высокого уровня доступности сервера. Однако бесперебойный доступ гарантировать невозможно.

5.1.8. Продавец гарантирует доступность сервера и работу приобретённой версии в течение минимум 1 года с момента покупки.

5.2. В соответствии с условиями настоящего Соглашения вы не имеете права:

5.2.1. Производить декомпиляцию и/или модификацию Программного продукта, использовать его компоненты в каких-либо других продуктах.

5.2.2. Удалять или исправлять в Программном продукте любые знаки о праве собственности и авторских правах на нее.

5.3. Настоящее Соглашение не предоставляет право на получение новой версии Программного продукта на безвозмездной основе.

5.4. Настоящее Соглашение не предоставляет Пользователю никаких прав в отношении товарных знаков или названий, принадлежащих Правообладателю.

5.5. Настоящее Соглашение предоставляет право Правообладателю разместить на своем сайте, в разделе с портфолио, логотип Пользователя.

5.5.1. Правообладатель обязан убрать всю информацию о Пользователе (в т.ч. логотип) со своего сайта по требованию Пользователя.

6. Срок действия Соглашения

6.1. Настоящее Соглашение и права, предоставляемые им, вступают в силу в момент установки Программного продукта и действуют в течение неограниченного периода времени (лицензия бессрочна).

6.2. По истечении срока действия Вашей лицензии на Программный продукт и в случае нежелания ее продлевать Вы обязаны деинсталлировать Программный продукт на Вашем компьютере.

6.3. Без ущерба каких-либо своих прав Правообладатель вправе прекратить действие настоящего Соглашения при несоблюдении вами его условий и ограничений.

6.4. При прекращении действия настоящего Соглашения Пользователь обязан уничтожить все имеющиеся у вас копии и компоненты Программного продукта.

7. Ответственность сторон

7.1. Правообладатель гарантирует, что Программный продукт соответствует требованиям законодательства Российской Федерации.

7.2. Правообладатель гарантирует, что работа Программного продукта будет соответствовать описанию, данному в документации.

7.3. Правообладатель не несет никакой ответственности в случае несовместимости Программного продукта с программным обеспечением на вашем компьютере.

7.4. Правообладатель не несет ответственность за какой-либо ущерб, связанный с использованием или невозможностью использования Программного продукта.

7.5. Правообладатель не несет никакой ответственности за последствия и ущерб, который может нанести Программный Продукт в случае несоблюдения Вами обязанности, указанной в пункте 4.2 настоящего Соглашения.

7.6. За нарушение авторских прав на Программный продукт нарушитель несет гражданскую, административную или уголовную ответственность в соответствии с законодательством Российской Федерации.

7.7. Пользователь должен предпринять надлежащие меры для обеспечения использования продукта внутри компании только в соответствии с лицензионным соглашением. Особенно это касается защиты от несанкционированного копирования программного обеспечения.

7.8. Пользователь несёт ответственность за любой ущерб, причинённый в результате нарушения авторского права или незаконного использования Программного Продукта.

7.9. Правообладатель не гарантирует сохранность данных, хранящихся в настройках и файлах Программного Продукта.

7.10. В обязанности правообладателя не входит системное администрирование и наладка Программного Продукта на Компьютерах Пользователя.

7.11. В обязанности Пользователя входит установка всех обновлений и новых версий Программного продукта из тех, которые доступны ему бесплатно. В противном случае, Правообладатель не несет никакой ответственности за работоспособность Программного продукта со своей стороны.

8. Заключительные положения

8.1. Правообладатель имеет право на изменение настоящего Соглашения в одностороннем порядке. Измененное Соглашение вступает в силу с момента его публикации на Сайте, если иное не оговорено в соответствующей публикации.

8.2. Настоящее Соглашение регулируется в соответствии с законодательством Российской Федерации.

8.3. Если какое-либо положение настоящего Соглашения будет признано аннулированным, недействительным, не имеющим юридической силы или незаконным, то остальные положения настоящего Соглашения сохраняют свою полную силу и действие. При противоречии условий настоящего Соглашения и условий какого-либо лицензионного договора о Программном продукте, заключенного между Вами и Правообладателем преимущественное значение имеют условия такого лицензионного договора, во всем остальном применяются условия и настоящего Соглашения, и такого договора.


Лицензирование RMS Удаленный доступ

Пакет программ для удаленного администрирования "RMS Удаленный доступ" (Remote Manipulator System) состоит из двух частей: Хост (устанавливается на удаленном компьютере), Клиент (устанавливается на локальном компьютере). Существует несколько типов лицензирования.

Классическая лицензия

Классическая лицензия подразумевает лицензирование каждого удаленного компьютера (модуль Хост). Рабочее место оператора (администратора) бесплатно (модуль Клиент).

Таким образом, если нужно управлять десятью удаленными компьютерами, то для этого необходимо 10 классических лицензий. Лицензионный ключ необходимо добавить только в «Хранилище лицензий» на Клиентах. На компьютеры операторов (администраторов), в этом случае, лицензии покупать уже не нужно. Число операторов неограниченно.

Данный тип лицензирования хорошо подходит для закрытых корпоративных сетей с большим количеством системных администраторов и персонала, который использует удаленный доступ.

Операторская лицензия

Операторская лицензия приобретается для каждого компьютера, за которым работает оператор или администратор, т.е. ПК, на котором установлен модуль Клиент, предназначенный для управления удаленными компьютерами. Количество же удаленных компьютеров (модулей Хост) неограниченно.

Можно управлять любым количеством удаленных компьютеров, приобретать лицензии на них, в данном случае, не нужно.

Данный тип лицензирования хорошо подходит для средних и крупных сетей с известным количеством операторов и любым количеством удаленных компьютеров, к которым нужен доступ.

Неограниченная лицензия

Безлимитная (неограниченная) модель лицензирования позволяет устанавливать программу, как на любое количество удаленных компьютеров (модулей Хост), так и на любое количество компьютеров операторов (администраторов) — модулей Клиент.

Докупать какие-либо дополнительные лицензии не нужно. В рамках одной организации достаточно одной безлимитной лицензии.

Эта модель лицензирования идеально подходит для крупных компаний, избавляя администраторов от забот о том, какое количество свободных лицензий осталось в распоряжении. Достаточно приобрести всего одну неограниченную лицензию.

Бесплатное лицензирование

RMS бесплатен как для физических, так и для юридических лиц. В Хранилище лицензий модуля «Клиент» вы можете получить бесплатный лицензионный ключ на 10 компьютеров (Хостов). Данный тип лицензии аналогичен классической лицензии, за исключением ряда особенностей.

Особенности бесплатной версии:

·Неограниченный и полный функционал программы.

·Бесплатная Лицензия предоставляется всем желающим полностью безвозмездно (бесплатно). При этом сохраняется возможность использовать данную лицензию в любых организациях, в т.ч. государственных и частных. Бесплатная Лицензия полностью бесплатна для физических и юридических лиц.

·«Internet-ID» есть.

·Возможно лимитирование количества трафика, используемого при работе через «Internet-ID». Приоритет отдается платным пользователям.

·Бесплатный лицензионный ключ можно получить в «Хранилище лицензий» Клиента.

·Максимальное количество удаленных компьютеров (Хостов), на которых можно использовать данную лицензию — 10 (десять).

·Нельзя использовать более одного лицензионного ключа Бесплатной Лицензии. Физическое или юридическое лицо имеет право использовать только один лицензионный ключ для работы.

·Бесплатная Лицензия не может использоваться одновременно с какой-либо другой лицензий, в том числе с другой Бесплатной Лицензией.

·Mini Internet-ID сервер доступен, в том числе и для пользователей Бесплатной Лицензии.

Лицензирование Сервера (Mini Internet-ID сервер)

Сервер полностью бесплатен для физических и юридических лиц. Его можно использовать при любом типе лицензирования RMS.

Порядок ввода регистрационного ключа

Видеоинструкция


Обратная связь

В случае возникновения каких-либо вопросов, касающихся использования, лицензирования или приобретения программы обращайтесь в службу поддержки.

Email: support@tektonit.com.

Посетите сайт программы, чтобы узнать о последних новости компании, новых версиях и обновлениях продукта.

Сайт компании: rmansys.ru.

Так же для Вас доступен русскоязычный форум технической поддержки, где Вы можете обсудить различные аспекты программы с другими пользователями и непосредственно с разработчиками продукта.

Форум: rmansys.ru/forum/.

Copyright © 2022 TektonIT. Все права защищены.